通达信量化MACD副图指标公式

hide2020-01-21  29

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

DIF:(EMA(C,5)-EMA(C,21))/EMA(C,21)*100,COLORF0F0F0;
DEA:EMA(DIF,8),COLOR00DCDC;
MACD:2*(DIF-DEA),COLORSTICK,COLOR0000DC;
STICKLINE(MACD>0,MACD,0,2,1),COLOR0000DC;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2,1),COLOR00B400;
STICKLINE(MACD<=0,MACD,0,2,1),COLORGRAY;
STICKLINE(MACD<=0 AND MACD>REF(MACD,1),MACD,0,2,1),COLORC800C8;
X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));
X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0+1)=X0+1));{回}
X2:=COUNT(MACD<REF(MACD,1),X1+1)=X1+1 AND COUNT(MACD<0,X1+1)<=2;
X3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);
STICKLINE(X1=0 AND MACD>0,MACD,0,2,0),COLORDCDC00;
STICKLINE(X3,MACD,0,2,0),COLOR0854FF;
NOTEXTDIF:DIF,COLORWHITE;
NOTEXTDEA:DEA,COLORYELLOW;
NOTEXT:IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORRED;
ER:=VOL/CAPITAL*100;
ZD:=C/REF(C,1)*100-100;
A0:=BARSLAST(CROSS(0.5,COUNT(MACD<0,3)>=3) AND (MACD>=1 OR DIF>=2));
A1:=CROSS(0.5,COUNT(MACD>REF(MACD,1),A0+1)=A0+1);
A2:=REF(HHV(ER,A0+1),1)>=3 AND REF(HHV(ZD,A0+3),1)>=5;
B0:=BARSLAST(A1 AND A2);
B1:=COUNT(MACD<REF(MACD,1),B0+1)=B0+1;
B2:=COUNT(MACD<0,B0+1)<=2 AND (COUNT(C<O AND ZD<0,2)=2 OR B0>=1);
B3:=B1 AND B2;
B4:=REF(B3,1) AND MACD>REF(MACD,1) AND C>O AND ZD>0;
DRAWICON(B4,ABS(MACD)+1,1);


最新回复(0)