通达信中短期多空副图指标公式

hide2020-01-21  25

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100; 
短多:SMA(RSV,3,1),COLOR6295FF,LINETHICK1; 
短空:=SMA(短多,3,1),COLOR979700,LINETHICK1; 
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100; 
中多:SMA(RSV1,5,1),COLOR000080,LINETHICK1;
中空:SMA(中多,10,1),COLOR282800,LINETHICK1;
DRAWBAND(中多,RGB(898,0,1),中空,RGB(05,58,58));
DRAWBAND(短多,RGB(248,918,18),短空,RGB(0,188,198));
短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLORWHITE,LINETHICK2;
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),COLORYELLOW;
中长期:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),COLORMAGENTA;
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLOR0000FF,LINETHICK1;

短期2:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLORFFFFFF,LINETHICK1;
中期2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),NODRAW ,COLORC0C0C0;
中长期2:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),NODRAW ,COLOR00A8A8;
周线:100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLOR1111FF,LINETHICK2;
GG:=WINNER(CLOSE)*100;
HH:=GG>50;
IF(HH,周线,DRAWNULL)COLORWHITE,LINETHICK2;
HH1:=GG>78;
IF(HH1,周线,DRAWNULL)COLORMAGENTA,LINETHICK2;
{VOL}
VOLUME:=VOL,VOLSTICK;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
MAVOL3:=MA(VOLUME,20);
MAVOL4:=MA(VOLUME,60);
{MA}
MA1:=MA(C,5);
MA2:=MA(C,10);
MA3:=MA(C,20);
MA4:=MA(C,60);
{J}
RSV3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV3,3,1);
D:=SMA(K,3,1),COLORLIBLUE;
J:3*K-2*D,COLORWHITE;

强市线:80,DOTLINE,COLOR000079;
弱市线:20,DOTLINE,COLOR000079;
分水岭:50,POINTDOT,COLORFFFFFF;
{}
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
HHJSJDB:=(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,COLORYELLOW;
HHJSJDC:=MA(HHJSJDB,5),COLORRED;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA),COLORSTICK;
DRAWICON(HHJSJDB>HHJSJDC,110,36); 
DRAWICON(HHJSJDC>HHJSJDB AND DIF>0,110,37);
DRAWICON(DIF>DEA AND DIF>0,130,36);
DRAWICON(DIF<DEA AND DIF>0,130,37);
{LON}
LC:= REF(CLOSE,1);
VID:= SUM(VOL,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100);
RC:= (CLOSE-LC)*VID;
LONG:= SUM(RC,0);
DIFF:= SMA(LONG,10,1);
DEA1:= SMA(LONG,20,1);
LON:=DIFF-DEA1;
LONMA:=MA(LON,10);
LONT:=LON,COLORSTICK;
BB1:=LON<REF(LON,1);
IF(BB1,J,DRAWNULL)COLORYELLOW,LINETHICK1;
DD:=LON>REF(LON,1);
IF(DD,J,DRAWNULL)COLORGREEN,LINETHICK1;
T11:=LON>REF(LON,1) AND REF(LON,1)<REF(LON,2) AND (LONMA-LON)<30;
DRAWICON(T11,J,1);


最新回复(0)